Author Topic: [IN DEVELOPMENT] NepsterLems for SL  (Read 693 times)

0 Members and 1 Guest are viewing this topic.

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
[IN DEVELOPMENT] NepsterLems for SL
« on: May 12, 2021, 05:23:21 PM »
I'm in the process of converting the .lvl copy of NepsterLems to .ini.

So far so good, although a few of the levels will not open in the 1.43 Editor and so cannot be converted. I get the following error message:



@ericderkovits | @kaywhyn - have either of you guys encountered this when converting level packs?

Do any NL 1.43/SuperLemmini users know what this means and what to do about it?

I've asked namida for the "past editors" downloads page link (which isn't on NeoLemmix.com) so I'll see if the levels will open in any version of the editor, and maybe see if they can be saved in a workable format.

If I can get past this hurdle, it's likely that we'll have a full copy of NepsterLems for SuperLemmini to look forward to :lemcat:
« Last Edit: May 21, 2021, 10:53:29 PM by WillLem »

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #1 on: May 12, 2021, 08:05:30 PM »
Update: the missing levels will open in the very next available version of the NL Editor after 1.43 (which, of course, cannot save files to .ini.

However, at least it shows that the level data is indeed contained within these files and so is not corrupted.

Does anyone have a copy of a NeoLemmix Editor prior to version 1.43? It can be any version, I just want to check if it can open the levels.

Offline kaywhyn

  • Posts: 1127
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #2 on: May 12, 2021, 08:30:21 PM »
As I mentioned on Discord, all the previous versions you can find on the Neolemmix Main board here on the Forums. v1.42 is on p. 13. And yes, the levels do open in the versions older than v1.43, as I tried it myself, but there is no way to convert to .ini. Seems that it's only possible on v1.43nc, but I get the exact same error as you do.
https://www.youtube.com/channel/UCPMqwuqZ206rBWJrUC6wkrA - My YouTube channel and you can also find my playlists of Lemmings level packs that I have LPed
kaywhyn's blog: https://www.lemmingsforums.net/index.php?topic=5363.0

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #3 on: May 12, 2021, 08:43:31 PM »
As I mentioned on Discord, all the previous versions you can find on the Neolemmix Main board here on the Forums. v1.42 is on p. 13. And yes, the levels do open in the versions older than v1.43, as I tried it myself, but there is no way to convert to .ini. Seems that it's only possible on v1.43nc, but I get the exact same error as you do.

The links on the page you mentioned actually link to Editor v10.12.12-C, hence why there's no way to convert to .ini.
« Last Edit: May 13, 2021, 12:41:53 PM by WillLem »

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #4 on: May 13, 2021, 12:42:00 PM »
Does anyone have a copy of a NeoLemmix Editor prior to version 1.43? It can be any version, I just want to check if it can open the levels.

Offline Forestidia86

  • Posts: 658
  • inactive
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #5 on: May 14, 2021, 02:14:35 AM »
Well you could try to convert the levels by hand/file editing. The NL new formats .nxlv files are human readable as well as the SL .ini files I think.
But this kind of converting will likely be an utter chore.

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #6 on: May 14, 2021, 09:17:25 AM »
Well you could try to convert the levels by hand/file editing. The NL new formats .nxlv files are human readable as well as the SL .ini files I think.
But this kind of converting will likely be an utter chore.

There are 29 levels which would need to be converted this way, and some of Nepster's levels are enormous. Maybe if I had a few people helping, I'd be willing to go ahead and do it this way. But I simply have neither time nor inclination to manually recreate all 29 levels. Maybe if it was just one or two, I'd probably have done it by now!

Unfortunately though, it is increasingly looking like that would indeed be the only way to do it.

I might see if I can get 4 people to do 5 levels each, and I'll do the remaining 9. It's a big "might" though!

Offline Forestidia86

  • Posts: 658
  • inactive
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #7 on: May 15, 2021, 06:15:25 PM »
Just out of interest:

Do the non-convertable levels use tileset mixing?
According to this thread tileset mixing was introduced in 1.47.

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #8 on: May 15, 2021, 07:18:33 PM »
I don't think so. I wondered that myself, but as far as I can see, there are no levels in NepsterLems which mix styles.

The first level which causes an issue is PLANET 3 "Another Miner Problem", which is entirely in the orig_fire set.

Even the level "A Study In Scarlet", which looks like it's been made in a custom tileset, is in fact a ridiculously complex layout featuring orig_fire letters, bars and a ton of erasers to create cubes - incidentally, if I was to take on the mammoth task of recreating the missing levels (unlikely), I'd almost certainly export this one as a PNG and use the resulting image as a custom tile.

I could even do the same for the others, with the obvious caveat being that they would all be low-res images. I suppose I could upscale them, but it's a far from ideal solution.

It's definitely a good idea to look at what the "unopenable" levels may have in common which makes them unopenable, but there isn't anything immediately obvious.

Offline namida

  • Administrator
  • Posts: 11608
    • View Profile
    • NeoLemmix Website
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #9 on: May 15, 2021, 07:50:15 PM »
My guess would be that Nepster originally created NepsterLems using V1.43, so many levels will open fine in V1.43's editor; but that he issued later updates using V1.47 (or higher), so the levels that don't open are the ones that were edited using V1.47 or higher's editor, while the ones that do are those that didn't need to be edited again.

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #10 on: May 16, 2021, 01:07:02 AM »
Yes, that certainly seems the most likely explanation.

I would like to get the pack converted, but I have far more pressing and important things to spend my time on at the moment (like learning Java, and focusing on getting irl stuff back on track after all the lockdowns). I have messaged Nepster and he may get back to me with a suitable suggestion, or some information which might help to find a solution.

In the meantime though, I'll have to put this project on hold.
« Last Edit: May 17, 2021, 04:38:50 PM by WillLem »

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED][ON HOLD]
« Reply #11 on: May 16, 2021, 01:24:36 AM »
Hmmm. After posting the previous message I decided to try opening one of the unopenable levels in SuperLemmini itself. I got an error regarding a missing music file, and so placed an audio file into the Resources/music folder with the same name as the missing file.

I was then able to open the .lvl directly in SuperLemmini.

Promising stuff. It may be possible to compile the pack from the .lvl files themselves rather than converting them to .ini.

I'm tired now, I'll come back to this tomorrow at some point :sleep:

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [HELP NEEDED]
« Reply #12 on: May 17, 2021, 05:30:47 PM »
OK. I'm a tiny step closer.

SuperLemmini will now successfully open and load all of the .lvl files that cannot be converted to .ini, albeit as External levels only.

As far as I can tell, it isn't possible to compile a level pack from .lvl files. I have specified in levelpack.ini that the relevant levels are indeed in the .lvl rather than .ini format, but for some reason it refuses to recognise these levels - in fact, throwing up the error "The resource styles//.ini is missing" when attempting to load them as part of a pack.

This is bizarre, since the engine is clearly capable of loading these same levels externally. There appears to be a format restriction on level packs and/or loading levels via the levelpack.ini system.



I've even tried opening the levels in the old jLevelBuilder, to no avail. Namida suggested that this is because the levels are in NeoLemmix-style .lvl as opposed to DOS/Windows .lvl, and so are in fact platform-dependent.



I've attached the levelpack as it currently stands, in case anyone else wants to have a look at it as well
« Last Edit: May 17, 2021, 10:03:45 PM by WillLem »

Offline WillLem

  • Posts: 1970
  • Just keep swimming
    • View Profile
Re: [IN DEVELOPMENT] NepsterLems for SL [RESOLVED]
« Reply #13 on: May 20, 2021, 12:44:09 AM »
OK... thanks to Turrican's informative reply to this post, I am now aware that there is in fact a nice easy way to convert late-old-formats-NeoLemmix .lvl files to .ini by opening them via the External Levels system and then finding the resulting level file in levels/$external.

The implications of this are actually more profound than you might think.

Not only will it now be possible to convert the entire NepsterLems pack, but it means that the most recent version of the NeoLemmix Editor to support save-to-lvl can be used to create SuperLemmini levels!, which is in fact 10.13.13!

I'm super tired right now, but given this new information I should be able to finish converting the remaining NepsterLems levels, and have the completed pack ready at some point tomorrow! :lemcat:

I'll also make a few test levels using 10.13.13 and gauge the basic possibilities there.
« Last Edit: May 21, 2021, 10:53:47 PM by WillLem »