Author Topic: [BUG][PLAYER] Progress no longer being saved/displayed  (Read 474 times)

0 Members and 1 Guest are viewing this topic.

Offline WillLem

  • Posts: 2221
  • "The quality of light around this time of year..."
    • View Profile
[BUG][PLAYER] Progress no longer being saved/displayed
« on: February 11, 2021, 03:29:07 AM »
Each time I fire up NL at the moment, it seems to reset all my levelpack progress, and I have to run a mass replay check on the pack I'm playing to restore the ticks.

Not sure whether it's a bug or something I'm doing wrong... ???

Offline WillLem

  • Posts: 2221
  • "The quality of light around this time of year..."
    • View Profile
Re: [BUG][PLAYER] Progress no longer being saved/displayed
« Reply #1 on: February 11, 2021, 08:10:38 PM »
I probably should mention that, whilst I always do new 12.XX versions as fresh installs, I then unzip all of my mods/settings to that new version.

If anything though, doing thing should preserve gameplay progress from previous versions, I would have thought...?

Happy to go back to manually changing settings if that's the issue, but I'm obvs hoping it isn't :forehead:

Offline namida

  • Administrator
  • Posts: 11884
    • View Profile
    • NeoLemmix Website
Re: [BUG][PLAYER] Progress no longer being saved/displayed
« Reply #2 on: February 11, 2021, 10:36:43 PM »
Can you try removing your userdata.nxsv file (feel free to just move it elsewhere rather than delete it) and see if your progress saves normally after that?

Offline WillLem

  • Posts: 2221
  • "The quality of light around this time of year..."
    • View Profile
Re: [BUG][PLAYER] Progress no longer being saved/displayed
« Reply #3 on: February 12, 2021, 07:54:59 AM »
Removing the userdata file did fix the issue initially, so I ran a bunch of Mass Replay checks again to restore progress, and now when I open NL I get the following errors:







This is intermittent: re-opening NL after closing the error dialogs usually resolves it, but the error does recur.

As a workaround for now, I'll simply delete userdata.nxsv and only restore progress from replays on the current pack(s) I'm playing; NL starts up much more quickly this way anyway.
« Last Edit: February 12, 2021, 08:06:11 AM by WillLem »

Offline namida

  • Administrator
  • Posts: 11884
    • View Profile
    • NeoLemmix Website
Re: [BUG][PLAYER] Progress no longer being saved/displayed
« Reply #4 on: November 16, 2021, 08:03:23 PM »
Are you still having any issues like this?

Offline WillLem

  • Posts: 2221
  • "The quality of light around this time of year..."
    • View Profile
Re: [BUG][PLAYER] Progress no longer being saved/displayed
« Reply #5 on: November 18, 2021, 08:26:44 PM »
Are you still having any issues like this?

To be fair, I've been using the workaround solution since I last posted here, so I wouldn't know if it's still an issue. At some point over the weekend I'll mass replay check all the packs I've played again (in 12.12.3) and see what happens.
« Last Edit: November 18, 2021, 09:05:32 PM by WillLem »

Offline WillLem

  • Posts: 2221
  • "The quality of light around this time of year..."
    • View Profile
Re: [BUG][PLAYER] Progress no longer being saved/displayed
« Reply #6 on: November 20, 2021, 03:43:09 PM »
After performing a mass replay check of many of the packs in NeoLemmix, I can confirm that 12.12.3 doesn't have any slowdown issues upon loading, and all progress is being saved as normal :thumbsup:

Offline namida

  • Administrator
  • Posts: 11884
    • View Profile
    • NeoLemmix Website
Re: [BUG][PLAYER] Progress no longer being saved/displayed
« Reply #7 on: November 20, 2021, 05:42:42 PM »
After performing a mass replay check of many of the packs in NeoLemmix, I can confirm that 12.12.3 doesn't have any slowdown issues upon loading, and all progress is being saved as normal :thumbsup:

The former is expected, but nice to hear it specifically confirmed with a large collection of levels and corresponding save data. The latter is what I'm really interested in here, and since that's confirmed working, I'll close this topic now. Feel free to create a new one if similar bugs resurface in the future.