Author Topic: [BUG] NL levels/replays cause Fewest Total Skills to appear as "-1" on Postview  (Read 763 times)

0 Members and 1 Guest are viewing this topic.

Offline ericderkovits

  • Posts: 913
    • View Profile
Here's something I found odd.

In the Lemmings in Weirdyland levels in Superlemmix, on the Postview screen it always shows the fewest total number of skills used as a -1. It shows -1 for every level.

https://www.youtube.com/watch?v=OFqMoM6DA-Q

Edit: weirdybeardys replays (saved in Neolemmix) do this. but when i replayed the 1st level without using a neolemmix replay it does say 3
« Last Edit: July 08, 2023, 11:52:45 PM by WillLem »

Offline jkapp76

  • Posts: 378
    • View Profile
I just completed weirdyland level 1 and it said total number of skills used 3.

*I am using a version of this pack that's been updated for SLX.
« Last Edit: July 08, 2023, 11:52:58 PM by WillLem »
...Jeremy Kapp

Online WillLem

  • Moderator
  • Posts: 3384
  • Unity isn't sameness, it's togetherness
    • View Profile
In the Lemmings in Weirdyland levels in Superlemmix, on the Postview screen it always shows the fewest total number of skills used as a -1. It shows -1 for every level.
---
Edit: weirdybeardys replays (saved in Neolemmix) do this. but when i replayed the 1st level without using a neolemmix replay it does say 3

Please can you send me the level, and the replay, that causes this. I can't replicate the bug in my copy of SLX 2.4.1.
« Last Edit: July 08, 2023, 11:53:06 PM by WillLem »

Online WillLem

  • Moderator
  • Posts: 3384
  • Unity isn't sameness, it's togetherness
    • View Profile
OK, since the bug was corrected by playing the level yourself, and the replay was made by a different user, I think I know what's causing this.

The record is only displayed at all if the level is "completed" - running someone else's successful replay will do this. But, since the record is by someone else, this part of the code hasn't actually been populated yet. To be honest, I'm surprised it doesn't outright crash the Postview screen!

Anyway, if that's what's causing it, it should be a fairly easy fix.

Another bug I spotted whilst testing this - the replay "R" isn't displayed in the panel when playing replays in Classic Mode. I know what's causing this as well - a previous bug caused the "R" to flicker on and off when rapidly changing RR (this actually happens in NL as well), and the fix to this prevents the "R" from ever being displayed in Classic Mode.

I'll get all this sorted for the next update (2.4.2).

Online WillLem

  • Moderator
  • Posts: 3384
  • Unity isn't sameness, it's togetherness
    • View Profile
This is fixed in commit 3f3a3c08c.

The bug was simply that records were being shown upon successful completion of a level, regardless of whether or not a user record actually exists. Since loading a successful replay "completes" the level, the records were erroneously displayed.

I've now updated the Postview screen to only show records when they're nonzero (or, more than -1 in the case of fewest skills, which could legitimately be zero in a level which only requires RR changes, or which otherwise doesn't provide, or use, skills).

See also this topic regarding Postview screen text after a test level.