Author Topic: How to play Lemmings 3D in DOSBox  (Read 2350 times)

0 Members and 1 Guest are viewing this topic.

Offline namida

  • Administrator
  • Posts: 10347
    • View Profile
    • NeoLemmix Website
How to play Lemmings 3D in DOSBox
« on: July 05, 2019, 08:51:27 pm »
Setting up Lemmings 3D for the official content can be a bit tricky, and for custom content even trickier due to the music patch being a bit confusing. So I've put together these packages to make it as simple and straightforward as possible for Windows users. (Mac / Linux users, see spoiler tag at end of post for the old version of this post, which is applicable there.)

Downloads - get ONE of these:
- Non-CD version (10MB): https://1drv.ms/u/s!Am6NTdy4vnPXg5xjv61p_3jBDM6JIQ?e=NNxsR1
- CD version (131MB): https://1drv.ms/u/s!Am6NTdy4vnPXg5xkrgJD_5yni9tgRQ?e=NMRpty

(The CD version includes CD audio and animations, but is otherwise identical. These downloads have all relevant patches pre-applied. Credit to Pooty for the CD music setup.)

Besides this, you'll also need to set up DOSBox: https://www.dosbox.com/download.php?main=1
After installation, open DOSBox's settings, and make some changes:
- "cycles=auto" -> "cycles=max" (under [cpu])
- "core=auto" -> "core=dynamic" (under [cpu])
- "output=surface" -> "output=ddraw" (under [sdl])
- "windowresolution=auto"; change "auto" depending on your desktop resolution and what size you want the window to be; for best results use an integer multiple of 320x240.

Now, to play Lemmings 3D - just fire up L3DUtils (included in the above download), and hit "Run L3D". If this fails, it might be that your DOSBox path is wrong - if so, hit the "..." next to it and locate your DOSBox EXE. (These downloads are preconfigured with the most common path for DOSBox 0.74-3.)

If you're using the non-CD version, you may want to install VirtualMIDISynth (freeware), and use the AWE32 rip soundfont for best results with the music. :)

If you have an existing savefile that you want to use with this setup, copy the LM3D.SAV file into "SAVE/DEFAULT/LM3D.CD". You can copy the LM3D.CFG file too if you like.



Some useful information:

- You CAN skip the intro, except for the first time you run L3D - just hold the space bar, and next time L3D transitions between intro screens, it'll jump directly to the title screen instead.

- Nuke is hard to activate by clicking; use the keyboard shortcut (Alt+Q) instead. Alternatively, if you want to exit to the title screen, press F11 (you'll be asked to confirm). You can also press Esc; this will go to the postview screen if you've saved enough lemmings to pass the level, or otherwise will insta-restart the level.

- Other useful keyboard shortcuts: Esc either restarts the level or exits it, depending on whether you've met the save requirement or not. Numbers 1 to 4 on the number bar (not the numpad) switch to the respective camera. Enter is fast-forward, P is pause. The various numpad buttons can be used to control the camera; some people find this preferable to using the mouse.

- On the subject of camera control with the mouse; the closer your mouse cursor is to the edge, the faster the camera moves. If you want to move forward slowly for example, move your mouse towards the top, but stop moving and start right-clicking as soon as it changes to an up arrow. If you want to move really fast, move the mouse right to the top of the screen. Similar logic applies for other directions. For more-precise control of vertical camera movement, click and drag the current location indicator instead of clicking in the empty space (like you would with an actual scrollbar in a typical desktop app).

- You can also click and drag on the minimap, to move the camera to the position you click, and face in the direction you drag. Note that some levels prohibit this despite having a minimap, such as Mayhem 65 "The Prisoner".




« Last Edit: November 11, 2019, 11:27:53 pm by namida »

Offline chrisleec728

  • Posts: 56
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #1 on: August 26, 2019, 02:18:35 pm »
Is anybody else having trouble getting "Armageddon" (aka nuke) to work on here?

Offline Pooty

  • Posts: 326
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #2 on: August 26, 2019, 07:20:48 pm »
If the game is running too quickly, the nuke is very hard to fire off. There are two ways of getting around this:

  • Press Alt+Q together to trigger the nuke.
  • If you're thinking of using the nuke to restart or to finish a level, you can alternatively press Escape. If you haven't saved enough lemmings, the level will restart. If you have, you'll move on to the next level.
SEGA Master System version
100% on 110/120 levels (92%). Other levels [Lemmings lost]:
Fun 03 [3], 06 [2], 18 [5]   
Taxing 19 [5], 27 [1], 28 [3]
Tricky 15 [5], 17 [2]
Mayhem 19 [7], 26 [10]

Offline namida

  • Administrator
  • Posts: 10347
    • View Profile
    • NeoLemmix Website
Re: How to play Lemmings 3D in DOSBox
« Reply #3 on: August 26, 2019, 07:26:34 pm »
^ As a third way, if you want to quit completely (note that this goes straight to the title screen, and discards your current attempt even if it's successful), press F11. You'll be prompted to confirm this by pressing (or clicking) Y.

Offline ccexplore

  • Administrator
  • Posts: 5289
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #4 on: August 26, 2019, 08:52:25 pm »
If the game is running too quickly, the nuke is very hard to fire off.

It was established on another thread that unless you're using an ancient PC (like, dating back from when the game was originally released), or running DOSBox in some unusual heavy debug mode that produces massive slowdowns, the game will almost certainly be "running too quickly" for you and will give you trouble with nuking.

Offline namida

  • Administrator
  • Posts: 10347
    • View Profile
    • NeoLemmix Website
Re: How to play Lemmings 3D in DOSBox
« Reply #5 on: August 26, 2019, 08:57:39 pm »
I had a PC that was very slightly older than the game itself, which nuking on via mouse was borderline impossible. I think you need even older than that. :P

But as Pooty mentions, the keyboard shortcut does not give difficulty. You do have to press both buttons at the same time (you can't hold Alt and then press Q), but the game is lenient enough that you're unlikely to have much trouble doing it.

Offline Pooty

  • Posts: 326
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #6 on: August 26, 2019, 09:05:52 pm »
It was established on another thread that unless you're using an ancient PC (like, dating back from when the game was originally released), or running DOSBox in some unusual heavy debug mode that produces massive slowdowns, the game will almost certainly be "running too quickly" for you and will give you trouble with nuking.

Well, I run my DOSBox in a fixed 50000 cycles, and I am able to double-click the nuke in all but the sparsest levels (e.g. Dot to Dot). I've set it this way because I think the animated objects in the game cycle too quickly.
SEGA Master System version
100% on 110/120 levels (92%). Other levels [Lemmings lost]:
Fun 03 [3], 06 [2], 18 [5]   
Taxing 19 [5], 27 [1], 28 [3]
Tricky 15 [5], 17 [2]
Mayhem 19 [7], 26 [10]

Offline namida

  • Administrator
  • Posts: 10347
    • View Profile
    • NeoLemmix Website
Re: How to play Lemmings 3D in DOSBox
« Reply #7 on: November 11, 2019, 06:26:34 pm »
I've updated the first post with some tips (at the bottom) on what might help to get CD music working, as well as how to get AWE32-like music in DOSBox (which doesn't support emulating an actual AWE32) - this is probably the nicest non-CD-audio option (and has the advantage over CD audio of that you get all 3 tracks for each style, whereas CD audio only has 2).

EDIT: Actually, screw that. I've put together some pre-configured downloads that make things as simple as possible - should, for most people, just be "install DOSBox, tweak a couple of DOSBox settings, then hit "Run"".
« Last Edit: November 11, 2019, 07:09:55 pm by namida »

Offline Toxifera

  • Posts: 5
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #8 on: April 26, 2020, 07:15:09 pm »
Hello Namida,
   I just wanted to thank you for your post, I appreciate your efforts. I followed all your instructions and downloaded the CD version, and made the appropriate changes to DOSBox config. I installed VirtualMidiSynth and the corresponding sound font. I also have GUS drivers installed for DOSBox because of my system config(2010 HP Mini 5103 running Win 10 64bit).
   I have created a GAMES directory on C:\ drive. I placed the L3D files in a LEM3D directory under GAMES. I also placed the Gravis Ultrasound files in a ULTRASND directory under GAMES(made the appropriate changes in DOSBox config). After I mount the GAMES directory, I run your L3DUTILS executable. It then stated "This program can't be run in DOS mode". Then I attempted to run the L3D executable. It stated that MSCDEX drivers canno't be loaded. As a side note, I was able to get the non CD version to run and MSCDEX drivers did load with no sound available.
  Any ideas? Thank You in advance.

Offline namida

  • Administrator
  • Posts: 10347
    • View Profile
    • NeoLemmix Website
Re: How to play Lemmings 3D in DOSBox
« Reply #9 on: April 26, 2020, 07:26:09 pm »
You need to run L3DUtils in Windows, not in DOSBox. When you click "Play game" in L3DUtils, it will launch DOSBox with L3D running in it (so it does still need DOSBox to be installed on your PC); but L3DUtils itself is a Windows app.

If you're mounting everything manually instead, then if you're using the CD version, you need to mount a CD drive in DOSBox. This can either be a physical drive with a real (or burnt) L3D CD in it, or an ISO image of the L3D disc - or the "dummy + audio" disc in one of the above downloads.

Offline Toxifera

  • Posts: 5
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #10 on: April 26, 2020, 09:35:46 pm »
Hey Namida,
   Thank You for the help. I was able to get L3DUTILS to work, It runs but I still have no sound. I do not have access to an ISO of the game. I also don't have access to a cd rom drive, would the ISO file work on a SD card? I searched the net for said ISO but was unable to acquire it. Would you have any info about where to find one? Thanks Again, Eric
   

Offline namida

  • Administrator
  • Posts: 10347
    • View Profile
    • NeoLemmix Website
Re: How to play Lemmings 3D in DOSBox
« Reply #11 on: April 27, 2020, 06:39:59 am »
The CD version link in the first post should have everything you need (except DOSBox). Point L3DUtils towards DOSBox, select the ISO file and point it towards the ISO from the download (though, this should already be configured), and hit play.

If you're not getting sound, try "Run Setup" and configure the sound hardware - Soundblaster for SFX, the same or General Midi for music.

Offline Toxifera

  • Posts: 5
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #12 on: April 27, 2020, 07:56:25 pm »
Hey Namida,
   Hope you're not getting tired of my issues. I have L3DUTILS pointed toward the latest version of DOSBox. I also received some incorrect info about GUS. I turned off the options in DOSBox config for GUS and turned on SB16. I also copied your L3D CD files to my SD card. I mounted my SD Card reader as a CD drive. The game plays fine but it still refuses to play the CD tracks.
   I purchased a Lemmings 3D game disk from the UK so that I can make an ISO file from, but it will be a while before I get the disc. I am an impatient bugger, would you know where I could download the actual ISO file of the original Lemmings 3D CD. In L3DUTILS, one of the the three selections is ISO. And it asks which directory it's in. I know I'm a noob but I think its asking for a literal ISO of the game disc. Thanks Again for your help. Eric

Offline namida

  • Administrator
  • Posts: 10347
    • View Profile
    • NeoLemmix Website
Re: How to play Lemmings 3D in DOSBox
« Reply #13 on: April 27, 2020, 08:16:32 pm »
Quote
In L3DUTILS, one of the the three selections is ISO. And it asks which directory it's in. I know I'm a noob but I think its asking for a literal ISO of the game disc.

If you used the CD download link above, there's a "dummy CD" image - the specific file you want to point L3DUtils towards is L3DCD.cue, but you need to have all of the files. The purpose of this is - the dummy ISO bypasses the CD check, and also redirects to the OGG files for CD audio, while not having the rest of the game data (to keep the filesize down), instead getting the game data from the local copy (rather than on a CD, virtual or otherwise). This doesn't matter too much if you're just playing the official levels, but it makes things much easier if / when you decide to make or play fanmade levels (which admittedly, there isn't many of yet - pretty much just my pack "Lemmings Plus 3D" + one level by Pooty).

Once this is done, you can run the game just by clicking "Run L3D" in L3D utils - you shouldn't need to manually mount anything in DOSBox, it should go straight into L3D when you click "Run L3D". (If it doesn't, do you have any MOUNT commands in your DOSBox AutoExec? If so, those may be interfering with L3DUtils launching L3D.)

Likewise, if you're manually mounting them, rather than trying to mount any kind of physical drive, use ImgMount and mount the L3DCD.cue file - I believe you need to specifically mount it as D drive for this to work.

If you want an original, unmodified L3D ISO, you can find a download here (torrent client required, I suggest QBittorrent, and in particular avoid uTorrent): https://archive.org/details/lemmings-3D

Offline Toxifera

  • Posts: 5
    • View Profile
Re: How to play Lemmings 3D in DOSBox
« Reply #14 on: April 27, 2020, 09:25:06 pm »
Thank You So Much Namida. It works perfectly, CD music and all :-). I have one last question. I have the screen res set in DOSBox config to 800x600. I also actually remembered (back in 95') that I actually got high res lemmings to work with the setting "- hi res" in the command line after L3D.exe, It was pretty sweet. I did that at the end of DOSBox config. It states in the startup window that High Resolution lemmings are activated, but it looks bad in full screen. What am I doing wrong? Thanks Again & Have a great week.  Eric